Wikia

GuildWars Fanfic Wikia

GuildWars Wikia:Style and formatting/Dye charts

Talk2
17,331pages on
this wiki

< GuildWars Wikia:Style and formatting | Redirected from User:Birchwooda Treehug/dye chart guide

Style guides
Yes

This page is a style and formatting guideline on GuildWars Wikia.

It has general acceptance among editors and is considered a standard to which articles should adhere. However, it is not set in stone and should be treated with common sense and the occasional exception.


Dye Chart GuideEdit

Gww project BT dye vials

Dye vials in order

Gww project BT crop

Step 2 - crop

Gww project BT cropped

Step 3 - all cropped

Gww project BT dragdrop

Step 5 - drag&drop

Gww project BT guides

Step 6 - Guides

Gww project BT all layers

Step 7 - result

Gww project BT all layers linked

Step 8 - linking

Gww project BT all layers merged

Step 9 - merging

Gww project BT select

Step 10 - selecting

Gww project BT linetool

Step 13 - line tool

Gww project BT linetool options

Step 13 - line tool options

Gww project BT texttool options

Step 15 - text tool options

Gww project BT dyemix

Step 16 - Dyemix text

Gww project BT textlayers linked

Step 17 - linking

Gww project BT layerstyle

Step 19 - layerstyle options

Gww project BT layerstyle pasted

Step 20 - layerstyle copy&paste

Gww project BT save1

Save - 4up view zoomed


Gww project BT save2

Save - naming

This is meant to be a help for newbies as well as for already experienced users. It's not meant to be a perfect or complete guide and so far only includes my own experience collected after ~200 dye charts. For suggestions and/or improvements you can leave a comment on its discussion page.
The guide is based on Adobe Photoshop (version 6 or higher), so if you use another program you'll have to search the equivalent options there by yourself.

PreparationsEdit

Before taking the screenshots, consider the following suggestions:

  • Have screenshots saved as BMP instead of already compressed JPG ( see: Command line for the how-to)
  • Graphic settings in game: Visual quality has 4 steps (1 fastest -> 4 highest), do not use 1 (simplified textures) and 2 (no animations and glows), 3 and 4 are fine. Set anti-aliasing to max (4x).
  • Keep in mind that different classes may hold an item differently. I experienced that a ranger or necro fits best as preview dyer, they also don't have outstanding underwear. Your dyer must show no armor on the pictures.
  • Enlarge your dye preview window to the max and then either zoom in/out or downsize the window again until the item fits well into the preview area. If only a smaller part is affected by dye you can zoom to that part. (Except for the resizing of the window you may have to do the zoom part for every dye, since with new dye added the preview angle will reset)
  • Stick to an order of coloring. Best is you sort the vials in your storage already in an order that you'll keep. It's up to you what you choose but I suggest that Red, Yellow and Brown are always on the upper row (if an item as a default color that can be replicated with a dye then it's one of those). My actual preferred order is:
    • 1st row - Brown, Red, Orange, Yellow;
    • 2nd row - Black, Gray, Silver, White;
    • 3rd row - Purple, Blue, Green.

Taking the sceenshotsEdit

Well not much to say here.
To take screenshots in game use the PRINT key on your keyboard.
Whether you take the screenshot of the default color with dye added or without (which I do) is up to you. But don't take 2 pictures of the same color if there's no noticeable difference.
Whether you add an uncommon color (e.g. pink, gold, yellow-green, babyblue etc.) is also up to you. If no mix is worth to show then don't force yourself to take an additional picture just to fill a slot in the chart.

EditingEdit

I'll write this part in a step-by-step guide so newbies can follow it. Means it will be long because of the detailed explanations.

  1. Start Photoshop, double click into the gray space (alternative: File > Open...) and go to your screenshot folder (usually located in: C:\Programs\GUILD WARS\Screens if you installed the game on C: in the programs dir), open the screenshots of the dyed item (you may want to change the view to thumbnail, also it's recommended to sort the files before by 'last change' [if ascending or descending doesn't matter]).
  2. With the Crop tool (C) you drag a frame around the item and then adjust the edges until only the item is in its frame. Commit the action when done.
  3. Switch to the Marquee tool (M), Ctrl+A (alternative: Select > All). Now drag the selection from your cropped image into one of the still undone images and place the rectangle over the item until it fits then crop via Image > Crop (new Ps versions may have a shortcut for it, older ones need Alt+I+C to do it). Do that with all images.
  4. Ctrl+N (alternative: File > New...), the new window should have a high enough resolution for all your cropped images. Make sure the rulers are active - Ctrl+R (alternative: View > Rulers)
  5. Switch to the Move tool (V) and drag & drop the first image into the new window. First one should be the the one with the default color.
  6. Drag a guide out of the ruler and place it on the edge of the image (it will dock automatically). Do that with all edges.
  7. Now drag all other images into the new document, give them their right place (your dye order) and add guides whenever necessary. The images will dock onto the guides automatically if moved in the near to one. Use that feature to have all your images in a perfect order. Please keep in mind you can only drag, drop and move images with the move tool active.
  8. Now link all image layers. Just have the upper one active and drag your mouse over the fields for the link symbol (beside the visible symbol) down to the first layer. That way linking is done in one move without clicking.
  9. Beside the Layers tab you see Channels and Paths and more to the right there's a small black arrow. Click on it to activate the layer menu and choose Merge Linked.
  10. (M) and drag a selection along the guides over your image. Crop it.
  11. Filter > Sharpen > Unsharpen Mask... Amount: 20%, Radius 1 pixel (default), Threshold 0 level (default). The image needs to be sharpened because we will save it as JPEG later and jpg blurries (depending on the compression value) more or less.
  12. Ctrl+A (alternative: Select > All), Alt+E+S (alternative: Edit > Stroke...) Width: 1 pixel, Color: Black, Location: Center, Normal 100% (default) - OK. That creates a 1 pixel outline around the image. Now to the lines within the image.
  13. Hold you mouse down on the Shape tool (above the Eyedropper tool) until a little menu pops out and choose the Line tool. On top of the Photoshop window you'll find its options. Mark 'Fill Pixels' ('Shape Layers' may be active by default), Weight 1 pixel, anti-aliasing deactivated. Your foreground color must be black to get a black line (press D if it's not black).
  14. Now drag lines along the guides inside of the picture (remember we already have a line outside around the image). Because the guides are also 1 pixel wide you won't see your new black lines. You can use Ctrl+H to disable and enable the guides and thus see your lines.
  15. The background is done, now the text. Text tool (T) and choose a font. I use Photoshop Small (ADMUI3Sm - a bitmap font, also called pixel font - see links for a site with free bitmap fonts [e.g.: HaxrCorp S8 tested]). Size: 10 pt, Anti-Aliasing: None.
  16. Type the dye name (for the default: <color> / default), move the cursor outside the typing field and it will turn into the move tool, move the text to a free corner until it docks onto the guides and press Ctrl+Enter (alternative: click on the 'commit' checkmark on top). Repeat that for every color. If you added a mix, write <name of mix> break (<color1> + <color2>).
  17. Link all textlayers as you did with the images layers before (no merge this time).
  18. Move tool (V), told down Crtl and press once a vertical arrow key and then a horizontal arrow key, which one depends on the corner your text is. This will do the following: a arrow key moves a layer by one pixel with the move tool active. When holding crtl it will move in 10 pixel steps instead. So the goal is to have the text 10 px from the edge. All linked layers will move too, means this step has only to be done once.
  19. Right-click on any text layer > Blending Options..., checkmark Drop Shadow - Distance: 0, Spread: 8, Size: 8, Quality: Gaussian curve, Anti-Aliasing yes; checkmark Stroke - Color: Black, Size: 1 pixel, Position: outside. OK (apply).
  20. Right-click on the very same layer again > Copy Layer Style, followed by right-click > Paste Layer Style to Linked. Now all linked textlayers got the same style.

With that the editing is done. Those are the steps repeated for every chart. No worries after several repetitions you'll be able to do this all with closed eyes within 10 minutes, but it'll stay a pretty boring work.
You can save the layer style (just click on New Style... in the layer style menu and think of a name) and then it's in the style window and can be applied by one click. Via actions you can even automate several steps (e.g. the linking, the merging, the styling and pasting, sharpening etc.).
Photoshop CS+ even offers the possibility to write complicated workflow scripts (too complicated for me =().

SavingEdit

Saving is one important part. It decides on quality and filesize.
Two things are to consider:

  1. Filesize = loadingtime. Not everyone on the world has DSL and not everyone with DSL has a flatrate and not everyone wants to waste bandwidth and/or volume on pictures that could show the same as smaller filesize.
  2. The quality should be enough to see and read everything clearly without that the pictures blurries that much that details are lost. But it is not necessary for a dye preview to offer best quality possible, it should only offer a preview of how it looks like to help with such important questions: "Will this blue axe fit to my blue armor?", "Is the purple of this wand the same purple as of my focus?", "How white will white be on this item?". As we know that dye looks differently depending on material and basic shade of the item.

The conclusion of those two points: Compress as much as needed but still keep details and a readable text.
In case of Photoshop this is done every easily since it offers not only a preview but also quality templates and estimated loading time for different internet speeds and filesize.

File > Save for Web...
Switch to the 4-up view and set the quality on Medium and on another field on High and compare look and filesize. You don't need to zoom as I did in my example (I only did it to show the differences in compressions which are easier to see when zoomed in).
To evaluate the quality on 100% is good enough, that's what the viewers will see too. So you either decide for the medium quality picture or the high quality picture. Best dye part for comparing is a reddish shade (red, orange, pink if present). Compare the medium one with the original and only when you think that it's too bad to publish save as high quality. Mostly the medium quality is fine (esp. filesizewise).
Hint: right-click on the filesize/speed info for other speed choices.

Naming

<Name_of_Item_dye_chart.jpg>
When I started I used colored because it's short and simple. The problem with 'Save for Web' in Photoshop is the limited characters in filename. You won't notice that while typing and while saving but when saved and the name was too long it will be crippled and you'll have to manually fix that either in your folder or when uploading. Keep in mind that Photoshop will replace empty spaces in a filename with a dash ( - ) and not an understroke ( _ ). Wiki however replaces understrokes with an empty space again, so we want an understroke in the filename ;)
If you made a mistake in the filename you can still change it in the upload menu in Wiki. However, once uploaded names can't be changed. You would need to upload the file again with the proper name and set a delete tag on the old one: {{delete|reason}}.

PublishingEdit

  • Click on Upload in Wiki (you must be registered and logged in), browse to your file. Here you can fix the file name (Destination filename) if necessary. Write [[Category:Dye charts]] in the "Summary:" box. Pick screenshot from the drop-down menu and you may want to uncheck 'Watch this page'.
  • Upload it. Copy the file title (e.g.: Image:Big Oven dye chart.jpg).
  • Go to the item's page and click on edit in the Dye section.
  • Type two square brackets ( [[ ) and paste the file name, add a | and write the preview width in pixels (e.g. 400px) and close it with two square brackets again ( ]] ). E.g.: [[Image:Big Oven dye chart.jpg|400px]]
  • Click on Show preview and if it looks fine end it with Save page.

LinksEdit

Guide ChangesEdit

  • 07. Aug. 08 - Switched Silver and Gray. Looks better with Gray coming before Silver since it mostly is darker.

Around Wikia's network

Random Wiki